BMW S1000RR Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello friends!!! I have a problem with my bmw s1000rr quick shifter. It works when it wants and i dont know why...know someone something? (Model 2015)
 

·
Premium Member
Joined
·
541 Posts
Is it plugged in properly???






btw you are probably going to be asked for more details by those that could really a have any insight into this, your diagnosis is extremely vague!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Is it plugged in properly???






btw you are probably going to be asked for more details by those that could really a have any insight into this, your diagnosis is extremely vague!
Yes it's from factory plugged in... And this problem is itself vague... It just works when it wants... I dont really know what happend
 

·
Registered
Joined
·
971 Posts
Hello friends!!! I have a problem with my bmw s1000rr quick shifter. It works when it wants and i dont know why...know someone something? (Model 2015)
Make a photo of it mate and attach here. Often the most common problem is that lever to rod angle is not 90
 

·
Vendor
Joined
·
2,833 Posts
aftermarket clutch lever = bad most likely

looks like your clutch perch is cracked and most likely your whole issue is the actuation of the micro switches not working correctly
 
  • Like
Reactions: Gixxerguy855

·
Registered
Joined
·
12 Posts
Discussion Starter #8
aftermarket clutch lever = bad most likely

looks like your clutch perch is cracked and most likely your whole issue is the actuation of the micro switches not working correctly
You think if I replace again the factory clutch lever it will work?
 

·
Vendor
Joined
·
2,833 Posts
I would at least try it on the lever.. is that perch cracked? It looks like it in the pic .. if the distance to the micro switch is not correct it is not going to work well or not at all.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
I would at least try it on the lever.. is that perch cracked? It looks like it in the pic .. if the distance to the micro switch is not correct it is not going to work well or not at all.
I havent this problem before 2-3 weeks...now without reasson do that
 

·
Premium Member
Joined
·
768 Posts
I would at least try it on the lever.. is that perch cracked? It looks like it in the pic .. if the distance to the micro switch is not correct it is not going to work well or not at all.
good eye!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
Guys the problem isnt the micro swichs or my lever because i did reset to quick shifter and worked normal...and after 2 days didnt work again and i did again reset and d worked...I dont know what's happening... Really
 

·
Registered
Joined
·
891 Posts
in talking with US BMW race support, apart from troubleshooting the clutch switch, these quickshifter units do fail. It has been recommended as one of the items to have at the race track as a common spare. They run about $200 on eBay
 
1 - 15 of 15 Posts
Top