BMW S1000RR Forum banner
1 - 4 of 4 Posts

· Premium Member
Joined
·
14 Posts
Discussion Starter · #1 ·
Hey guys not sure if this is the right area to post.

I have a 22 model s1000rr with 35 miles on it. I've lowered it 1" and installed the tst tail lights that's it. All of a sudden after doing the tst taillights I have a fault in engine control unit on. It comes on everytime bike is started.
Today I noticed the gauge said 42 miles to empty so I went to gas station. It took 2 gallons to fill it up but after driving back home the gauge now says 38 miles to empty. Any ideas?




https://imgbb.com/
 

· Vendor
Joined
·
5,258 Posts
The fuel gauge is not involved in any of the rear wiring.

The fuel level is a calcualation. Sometimes it takes riding the bike several miles for the calculation. I see you said you rode it home, but that depends on how far.

Then the float might be stuck. Seems there was another post from someone last year that the fuel level was not correct on a K67. I have never seen the issue on any of my 4 K67 bikes.

Your error on the cluster is likely a light warning. Go in the settings and turn off the light warnings message. Then you can ask TSI why they designed their replacement lights that dont work with the BMW software warnings.
 

· Registered
S1000RR 2022 M Package
Joined
·
9 Posts
Had the same warning a couple of days ago. Took it to the dealership as soon as it happened. The mechanic there told me it can happen when starting in really cold days, and it's better to just ride it a bit, turn off and on again, and if the message is still on, then, it might be a real problem, otherwise it seems like a false positive. Just my 2cents on this
 
1 - 4 of 4 Posts
Top