BMW S1000RR Forum banner

2014 S1000rr pump not priming??

2572 Views 14 Replies 3 Participants Last post by  bennymx
Hey guys so I have a 2014 S1000rr but yesterday I was riding and had only been riding for maybe 10-15mins when all of a sudden the throttle quit responding and the bike died I still had power to the bike but when I tried to start it WITH kill switch on, bike in neutral all that good stuff it would crank but not start and no fuel pump priming. So I took my back seat off and my power commander 5 has no power the bike has had absolutely no problem starting or running at all since I installed the power commander which is all I have no auto tune or qs but the weather has been cold here recently but I keep my bike under a cover when it’s outside and like I said it started perfectly fine that morning let it warm up to temp then rode 10mins down the road when it died on me.

I’ve since taken the tank off checked wiring and connections, fuses, unhooked power commander and still no fuel pump priming. Any help would be appreciated if anyone has had a similar problem!
1 - 3 of 15 Posts
Maybe the fuel pump is bad. Get one used off ebay. make sure it is for the 12-14.

Get a GS911 and see if it will turn on the fuel pump then you will know if it is bad, or if there are any codes related to the fuel system.
Get a GS911. There are codes that do not present a check engine light or code info on the LCD panel.

Fuel pumps are a wearing consumable item. They go out at anytime. Not on some schedule of time or miles.
Okay will do I’ll let you know the outcome
You need to check if power is coming from the DME to the pump connector. Sounds like the electronic fuse is tripped or the DME is faulty.
Since he indicates there is no DME Fuse Error Level in the GS911, the ECU should be ok and not in a needed reset mode. However, I have seen the fuel pump driver go bad in the DME and this does not present an error. Clone and Replacement of DME is needed. If you get to this point of thought I have the DME's in stock and can clone and test this issue for you.
1 - 3 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.