OBDLink and MX+ - BMW S1000RR Forums: BMW Sportbike Forum
 
LinkBack Thread Tools
Old 09-16-2019, 05:22 PM Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 5
OBDLink and MX+

I purchased the OBDLink MX+ and the Motoscan Professional. I was able to reset the warning light but have been unable to reset the service date or mileage. My bike is a 2016 S1000RR.
I was getting this message when connecting to the OBDLink app. (pic 1)

When connecting to the MotoScan App Iíve got this message. (pic 2)

I contacted the MotoScan developer and was told that app is not fully functional with 2016 or earlier S1000RR's.

This was news to me but MotoScan developer also replied they hoped to have a bug fix out this week. Has anyone else have experience with this?
Attached Thumbnails
Click image for larger version

Name:	IMG_8640.jpg
Views:	33
Size:	9.1 KB
ID:	202880   Click image for larger version

Name:	IMG_8643.jpg
Views:	24
Size:	8.8 KB
ID:	202882  
nedmoto is offline  
Sponsored Links
Advertisement
 
Old 09-16-2019, 08:26 PM
A B
Senior Member
 
A B's Avatar
 
Join Date: Mar 2010
Location: Canberra, Oz
Posts: 877
Garage
I have a 2016 and the OBDLink LX (bluetooth), and Motoscan Pro, but I have to use my old phone (HTC) as my Nokia 6.1 wont keep a bluetooth connection.

I think its something to do with the bluetooth version running on newer phones.

I got the same as your first picture with my nokia, switched to old phone it worked fine - I had to reset my bikes system date as it defaulted to 2000 after a new battery. With my old phone I can also activate the ABS valve when totally draining and replacing brake fluid.

So I think its the OBDLink which has the bluetooth isssue, not Motoscan app.

1990 Carrera 4 | 2016 S1000RR | 2010 S1000RR (gone)
A B is online now  
Old 09-16-2019, 10:58 PM Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 5
That thought was never crossed my mind regarding the bluetoothbut I am using an older Samsung Galaxy J3a. Wladimer from MotoScan did reply that V.61 would be out this week to fix a bug with pre 17 S1000rr's. I also created a ticket with OBDLink for their app but I haven't heard back. I did order another BMW cable thinking that might be it but I received that today with the same result.
nedmoto is offline  
 
Old 09-16-2019, 11:12 PM
A B
Senior Member
 
A B's Avatar
 
Join Date: Mar 2010
Location: Canberra, Oz
Posts: 877
Garage
HTC One m9 is bluetooth 4.1
Nokia 6.1 is bluetooth 5

your Samsung Galaxy J3a is bluetooth 4.0/4.1

so yeah, dunno what to try next...

1990 Carrera 4 | 2016 S1000RR | 2010 S1000RR (gone)
A B is online now  
Old 09-16-2019, 11:22 PM
A B
Senior Member
 
A B's Avatar
 
Join Date: Mar 2010
Location: Canberra, Oz
Posts: 877
Garage
googling I found the OBDLink forum, and it seems to imply that it has issues with a 6 digit bluetooth paring code which is used on later Android versions?

https://www.scantool.net/forum/index...&topic=15969.0

I'm going to check the firmware version of mine tonight when I get home. from that forum:

Quote:
Have you upgraded your firmware to version 4.5.2? It appears the only change for that firmware version is changing to a 4 digit bluetooth code, which will solve the unable to pair issue for those of us with Android head units that won't pair using 6 digit codes.

1990 Carrera 4 | 2016 S1000RR | 2010 S1000RR (gone)
A B is online now  
Old 09-17-2019, 05:47 AM
A B
Senior Member
 
A B's Avatar
 
Join Date: Mar 2010
Location: Canberra, Oz
Posts: 877
Garage
So my Nokia paired to the LX, upgraded firmware to 4.5.2, turned it all off, re-paired no worries, but it was the 6 digit pair code.

Then can't communicate with bike, but can communicate with LX.

old phone still communicates fine. So I reckon it's an issue with Bluetooth version.

Sent by shoephone via Tapatoe

1990 Carrera 4 | 2016 S1000RR | 2010 S1000RR (gone)
A B is online now  
Old 09-17-2019, 08:44 PM Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 5
Upon re-pairing the phone I did have a six digit code and had the same result.

I did get this back today from OBDLink Tech Support:

"The OBDLink app, by default, only connects to OBD-II (emissions related) data. Motorcycles are not required to be OBD compliant. I believe the OBDLink app will not connect to your specific motorcycle."
nedmoto is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW S1000RR Forums: BMW Sportbike Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome