Can a 190/50 work - Page 3 - BMW S1000RR Forums: BMW Sportbike Forum
LinkBack Thread Tools Display Modes
post #21 of 22 (permalink) Old 11-23-2012, 06:59 PM Thread Starter
Join Date: Jun 2012
Location: Maryland
Posts: 84
So the 50's were point on I could instantly feel the difference. My overall impressions of the Q2 were good during the 70 or so miles I rode. The electronics were ok, but when the bike was in sport mode the TC was having a panic attack. When I switched it into race mode no problem. I'm going to stick it out with the Q2 for the moment. Thank you all who chimed in with there comments and insight.

Thanks, Zoom
ZoomMp7 is offline  
Sponsored Links
post #22 of 22 (permalink) Old 08-09-2013, 12:39 AM
Senior Member
HarperS1K's Avatar
Join Date: Jul 2013
Location: Salt lake city
Posts: 175
Old thread but I'm going to put my experience in anyways

i just installed my 190/50 Diablos today and the traction light is flashing on acceleration only and in rain mode. But it doesn't do it in sport thankfully.

Sent from Free App

Stay thirsty my friends. KCCO!

Last edited by HarperS1K; 08-10-2013 at 03:14 AM.
HarperS1K is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the BMW S1000RR Forums: BMW Sportbike Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome