Bike stuttering! :( - Page 2 - BMW S1000RR Forums: BMW Sportbike Forum
Go Back   BMW S1000RR Forums: BMW Sportbike Forum > General BMW S1000RR Discussions > Exhaust and Fuel Delivery


» Insurance
» Sponsors
Reply
 
LinkBack Thread Tools Display Modes
Old 11-22-2012, 01:39 PM   #11 (permalink)
Member
 
KaoZ's Avatar
 
Join Date: Jul 2012
Location: Belgium
Posts: 51
Garage
Default

Quote:
Originally Posted by pekespeed View Post
Did you fix the problem?
The bike is still at the BMW dealer (for 3 days and counting)
The mechanic is still convinced that the registration key for the exhaust is the problem, but he keeps looking for something that's broken.
Could a PCV replace this key? Because that is half the price (550$ vs 250$

I still find it weird that multiple users on this forum have a full system without the key and don't have any problem.

Last edited by KaoZ; 11-22-2012 at 01:44 PM.
KaoZ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-22-2012, 05:16 PM   #12 (permalink)
Senior Member
 
Join Date: Oct 2012
Posts: 270
Default

Sorry i dont mean to thread jack but i was very interested in buying a s1000rr 13 or the Hp4 version but it seems that alot of things needs to be replaced or added if one decides to do some minor modifications to the bike. I'm not a s1000rr owner yet so what is this key that might be needed for the bike.
erion racer is offline   Reply With Quote
Old 11-22-2012, 06:02 PM   #13 (permalink)
Lifetime Member
 
skapan's Avatar
 
Join Date: Jul 2011
Location: Toronto Canada
Posts: 1,428
Default

You don't need the key, you need another dealer. Ask them to try running it with the O2 sensors disconnected. Then figure out which one is bad, replace it and you're back on the road. The "key" they are talking about is for the full race ECU system, and it won't even work on your ECU if you're in the USA, you also need the "race" ECU. Your proof is that it was running fine before "something" happened.
skapan is online now   Reply With Quote
Old 11-23-2012, 10:23 AM   #14 (permalink)
Member
 
KaoZ's Avatar
 
Join Date: Jul 2012
Location: Belgium
Posts: 51
Garage
Default

Just got the bike back.
The problem was that there was some oil/fuel on one of the spark plugs.

He also test drove it, and he felt little power under 5k rpm. And I can agree with him on that. Maybe it's time to invest in a PCV / Bazzaz / Rapidbike?
KaoZ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 07:55 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© S1000RRforum.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum