Removing exhaust valve's servo's/motor's info - BMW S1000RR Forums: BMW Sportbike Forum
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-01-2012, 04:18 AM Thread Starter
Senior Member
BUZZ's Avatar
Join Date: May 2010
Posts: 1,181
Removing exhaust valve's servo's/motor's info

Some one enlighten me,im running a full exhaust system and disconnected all the cables that used to be connected to the stock exhaust,so my question is can the exhaust valve servo's be removed and disconnected and will the bike show up any fault codes on dash or is there something in the hp parts list that corrects any fault codes once disconnected.???????? Cheers

2011 motor sport s1krr,puig dark screen,watson flush turn signals,hp levers,hp rearsets,pcv,k&n race filter with custom map,austin racing gp2 inconel and titanium exhaust system,sharkskinz belly pan and stock panels custom painted,r&g crash protection,gb racing engine covers,factory pro detent spring,symmetrical smoked headlight covers,pro suspension set up and one crazy rider..!!!!
BUZZ is offline  
Sponsored Links
post #2 of 6 (permalink) Old 11-01-2012, 06:05 AM
Senior Member
Jax0238's Avatar
Join Date: Jul 2012
Location: Vilseck, Germany
Posts: 987
I'm pretty sure it does throw a code but is considered a soft code as it does not show up on the dash but can be read by the dealer when hooked up for diagnosis. Could be wrong but I disconnected my rear servo and never showed a code on the dash but dealer said there was a code showing up in diag.

Sent from my iPad using MO Free
Jax0238 is offline  
post #3 of 6 (permalink) Old 11-01-2012, 07:07 AM
Lifetime Member
skapan's Avatar
Join Date: Jul 2011
Location: Toronto Canada
Posts: 2,515
I saw a post somewhere that even with the servo motors removed the ECU showed the same fault code as the cables disconnected. You could try unplugging them as a first step, then if there's no issues go ahead and remove them. I kinda like that clack clack noise when I turn on the key, so I left mine on.
skapan is online now  
post #4 of 6 (permalink) Old 11-01-2012, 09:43 AM
Lifetime Member
yangins's Avatar
Join Date: Oct 2011
Location: Green Bay, WI
Posts: 1,145
I have all my servo remove no light at all. Does through internal codes but no effect on how the bike runs.

Mad Yellow Bumble Bee

Current Street squiding bike
1993 EX-500
Honda XR100 Mini Supermoto
yangins is offline  
post #5 of 6 (permalink) Old 11-09-2012, 08:00 PM
Senior Member
DannyD's Avatar
Join Date: Apr 2012
Location: Baltimore MD
Posts: 125
Installing a full exhaust as I type this servos and cables removed no "real"issue? Just clarifying???

Sent from my iPhone using Free App
DannyD is offline  
post #6 of 6 (permalink) Old 11-09-2012, 08:47 PM
Lifetime Member
skapan's Avatar
Join Date: Jul 2011
Location: Toronto Canada
Posts: 2,515
That's right, only your dealer will know for sure.
skapan is online now  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the BMW S1000RR Forums: BMW Sportbike Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome